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2 Getting Started 

2.1 Installation 

1. Download the software from the site: http://terminus.wintringham.ch and save the 
installation files, for example, to your desktop. 

2. The installation consists of a number of setup files all embedded into a single ZIP file for 
convenience. Extract the files into a folder, if necessary. 

3. Run the setup.exe file from your desktop or folder and select the default options. 
4. Start the application from the program menu or the icon on your desktop. 
5. Depending on the Terminus version, you may be asked to verify the digital signature. 

Select “Open” to continue. For more details, please read the section on digital signatures. 
 

Terminus starts in the main terminology form. This is used to enter, edit and view your 
terminology. 

 

2.2 Registration 

1. Open the registration form using the menu option Options → Registration. 
2. Enter your registration name, code and any additional information. 
3. Close the registration form using the “Exit” button. 
4. You may need to restart the application for the changes to take effect. 

 
If you do not have a registration code, please contact support.  

 

2.3 Languages 

1. Open the language form using the menu option Options → Language. 
2. Set the language names that you wish to use in this database. These values are used to 

display the languages on the main terminology form, search screens and on reports. 
3. Set the first language to be the language that you are likely to use most as many of the 

options and lists will default to this language. Set the other languages in order of 
decreasing importance. 

4. Optionally you may set a colour that corresponds to each language. These colours are 
used on the search results screen to easily identify the different languages. 

5. Close the language form using the “Exit” button. 
6. You may need to restart the application for the changes to take effect. 

 

2.4 Descriptors 

1. Open the descriptor form using the “Descriptor” button on the main terminology form. 
2. Enter the up to 20 characters for each descriptor and a short description. 
3. Close the descriptor form to return to the main terminology form. 

 
Before you decide on your descriptors, I suggest that you read the section “Organising your 
data”. 

 

2.5 Entering Data 

You manually enter data using the Terminology form. Fields are provided for terms in all your 
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selected languages, terminology source and context. Each term must have a main descriptor 
and by double-clicking on available descriptors you can add additional descriptors. 
 

2.6 Searching 

1. Open the search form using the “Search” button the main terminology form. 
2. Enter your search criteria in the search box. 
3. Press return or click on the search button to display your results. 

 

2.7 Reports 

1. Open the print form using the “Print” button the main terminology form. 
2. Select the languages, descriptors, sort order and style that you wish to view on the 

report. 
3. Click on the print preview button to display your results or alternatively click on the print 

button to print your data on the selected printer. 
 

2.8 Import 

1. Open the import file select dialogue using one of “Import” menu options on the “Data” 
menu. 

2. Select the file that you wish to import. 
3. Map the database languages with the language tags defined in the file that you wish to 

import. Languages not mapped will not be imported. 
4. Either Map the descriptors and additional descriptors to fields in the import file or set 

values for these fields explicitly. 
5. Import the data using the “Import” button. 
6. Close the import form to return to the main terminology form. 

 

3 Forms 

3.1 Terminology 

The terminology form is designed for the manual entry of data. Each term must have a 
descriptor and should contain at least one language term. Optionally, a term may have source, 
context and additional descriptor values. Complete the data entry either by using the Enter key 
or by moving to the next record. 
 
Descriptor Select a descriptor from the drop down list. This field will default to 

the value last used. 
Language Enter a term or select a term from the drop down list. 
Source Enter a source or select a source from the drop down list. 
Context Enter a context value. 
Additional Descriptors The left hand column displays the available descriptors. The right 

hand column, the values selected for this term. Double click on a 
descriptor in the left hand column to add an additional descriptor for 
this term. Double click on a descriptor in the right hand to remove the 
additional descriptor. 

Sort Sort the terminology by language or date. The default sort order is 
alphabetically on the first language displayed on the page. 

Created Displays the date and time that the entry was created. 
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Modified Displays the date and time that the entry was last modified. 
 
Print Terminology Print and export terminology. See print form for details. 
Open Descriptor Add, modify or delete descriptors. See descriptor form for details. 
Open Search Comprehensive terminology search. See search form for details. 
Search / Set Filter Simple search filter to limit the displayed terms to those that match 

the requested pattern. Use clear filter to show all terms. 
Clear Filter Clear the current filter and display all terminology. 
First Record Display the first term in the current terminology set. Both the current 

filter and the sort order will influence what is considered to be ‘first’. 
Previous Record Display the previous term in the current terminology set. 
Next Record Display the next term in the current terminology set. 
Last Record Display the last term in the current terminology set. 
Add Add a new term to the database. 
Delete Delete the current term from the database. 
Exit / Close Exit the Terminus application. 
 

3.2 Descriptor 

Add, modify or delete the descriptors.  
 
Descriptor The descriptor may be up to 20 characters long and should not 

contain either a comma (,) or a semi-colon (;). 
Description Enter a description. 
Entries Displays information on the number of terminology entries for each 

descriptor. The left hand column displays the number of terms that 
use this as the main descriptor. The right hand column, the number 
of terms that use this as an additional descriptor. 

Add Add a new descriptor to the database. 
Delete Delete the current descriptor from the database. An arrow in the left 

hand column defines the current descriptor. 
Close Close the descriptor form and return to the main terminology form. 
 

3.3 Import 

Import data from a text file or spreadsheet. Choose the file format by selecting the appropriate 
“Data” menu option. 
 
Import Columns From File 
Descriptor Select a column from the import file to map to the descriptor. 
Additional Descriptors Select a column from the import file to map to the additional 

descriptors. 
Languages Select a column from the import file to map to each of the languages 

to import. 
 
Override File Descriptors 
Descriptor Select a descriptor from the database to use for all imported 

terminology. 
Additional Descriptors Select descriptors from the database to use as additional descriptors 

for all imported terminology. 
Import Import the terminology. 
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Close Close the import form and return to the main terminology form. 
 
If descriptors and additional descriptors are both mapped from the import file as well as set to 
override values then the import values will be ignored. 
 

3.4 Print 

The Print form provides options for printing or exporting terminology. Options include which 
languages to display, how the terminology should be sorted and whether to include descriptor or 
Context values.  
 
Languages Specify which languages to display on the report. 
Sort Specify the sort order. This will also influence which language 

appears in the left hand column of the report. 
Report Type Select whether the report should be printed in either portrait or 

landscape modes and also if the report should display data grouped 
by the main descriptor. 

Include Context Include context field in export. Context is only displayed in CSV and 
RTF exports. 

Include Additional Terminology Include terminology on the report if the selected descriptors 
are set in the terms’ Additional Descriptor field. Without this option, 
only terms that have the descriptor set as the main descriptor will be 
included in the report. 

Report Title Define a report title. This will replace the default report title. 
Descriptors Select which descriptors should be displayed on the report. If no 

descriptors are selected then all terminology will be printed. 
 
CSV Export Export the data in text (CSV) format. See Import / Export Format for 

details. 
RTF Export Export the report in RTF format. 
Preview Preview the terminology report. 
Print Print the terminology report to the selected printer. 
Close Close the print form and return to the main terminology form. 
 

3.5 Print Preview 

Preview the report before printing. To close the preview form, either right-click on preview form 
background and select Close or use the Close Window in the top right of form. In some versions 
of Access, the close window button is missing from the print preview windows. For these 
versions, please use the Close Reports menu option to close the window. 
 

3.6 Search 

Query the database. Enter a query or select a value from previous queries. 
 
Query Enter or select a search value. If this value is not set then all 

terminology will be displayed. This field stores the last 10 search 
values allowing the user to quickly return to previous search results. 

Descriptor Search Select a descriptor to limit the number of results. 
Include Additional Terminology Also search for the descriptor in the Additional Descriptors 



Terminus Terminology Database Version 3.1 March 2009 
 

 
 Copyright © Nils Wintringham, Wilco GmbH 1997 – 2009 Page 7 of 13  

field. 
Search Language Select the language(s) to search. 
Display Language Select the language(s) to display. Search languages are always 

displayed. 
Sort By Sort by language, descriptor or date. 
Whole Word Search for whole words only. 
Report Title Define a report title. This will replace the default report title. 
Search Perform the search or press the Enter key. 
 
Results Displays the results of the query. Clicking on a term copies the term 

into the clipboard buffer.  
Double clicking on a term switches the form to the main terminology 
form and displays the selected term. This also sets the current filter 
to match the query results. Selecting the search button on the main 
terminology form switches back to the query results. See also Clear 
Filter on the terminology form. 

 
Edit Terminology Using the Edit Terminology button has the same effect as using 

double click in the results window. If, however, no term has been 
selected in the results window the terminology form will display the 
first entry in the result set. 

Print Print a terminology report based on the search results. 
Preview Preview the terminology report. 
Close Close the search form and return to the main terminology form. 
 
For reasons of speed, a maximum of 2000 terms are displayed in the results window. If the 
number of results exceeds 2000, the results are displayed in italics and a notice is displayed 
underneath the results window showing the total number of matches. The report preview and 
print will, however, display and print all terminology. 
 

3.7 Database 

Terminus allows you to use any number of databases. Use this dialogue to open and use a 
different set of terminology. The default database is entitled “Terminus_Data.mde”.  
 
You should remember to make regular backups of all terminus data files. 
 

The dialogue is located on the menu under File → Open Database. 
 

3.8 Printer Setup 

Select the printer to be used for all reports. This is initially set to the windows default printer. 
 

The dialogue is located on the menu under File → Printer Setup. 
 

3.9 Language 

Define the languages and the colours to be used in this database. Please note that changing 
the language will not change the terminology. 
 
Language Set the name of each language. 
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Colour Set the colour of each language. 
Default Colours Reset the colours to their default values. 
 

The dialogue is located on the menu under Options → Language. 
You may need to restart the application for the changes to take effect. 
 

3.10 Advanced Mode / Edit Mode Colours 

Terminus supports an option that allows beginners to confirm changes that they have made to 
their terminology. Advanced mode disables this feature and allows for much faster manual entry 
of data. 
 
View Mode Colour Set the default background colour. 
Edit Mode Colour Set edit mode background colour. 
Default Colours Reset the colours to their default values. 
Advanced Mode Switch between beginner and advanced mode. 
 

The dialogue is located on the menu under Options → Mode. 
You may need to restart the application for the changes to take effect. 
 

3.11 Registration 

Enter your registration data. Please enter these values exactly as provided by the Terminus 
support team. If you do not have a registration code, please contact support. Please note that 
the Terminus functionality is limited in unregistered versions. Please note also that a registration 
details cannot be changed. 
 
Registration Name Enter the name used to register Terminus. 
Registration Location Enter the location used to register Terminus. 
Registration Code Enter the code provided by the Terminus support team. 
 

The dialogue is located on the menu under Options → Registration. 
You may need to restart the application for the changes to take effect. 
 

3.12 About 

This dialogue displays: 
● Application version and support details, 
● Registration information and 
● Details about the Terminus database that is currently in use. 

 

The dialogue is located on the menu under Help → About. 
 

4 Organising your data 
Terminus allows you to organise your data into different subjects, glossaries or groups. It does 
this by allowing you to associate your terminology with one or more classifiers known as 
descriptors. Each term has one main descriptor and as many additional descriptors as you 
need. Using these descriptors, you will be able to search and report specific terminology for the 
groups that you have defined. 
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While the use of descriptors is not necessary, it is important to understand how the classification 
works so that you gain the full benefit of descriptors if you so wish. 
 
Each term has one main descriptor and zero or more additional descriptors. When searching 
and reporting terminology, it is possible to limit the search to one or more descriptor. On 
extremely large databases, this may reduce the number of terms that match the search criteria, 
which will simplify finding the term that you are looking for. It will also allow you to display all the 
terms stored in a particular group. 
 
For example, if you set up descriptors for sport and you were trying to classify the term ‘dive’ in 
your database, it would be useful to be able to differentiate between Football and Swimming. To 
do this, simply add the Football descriptor to the Football term and the Swimming descriptor to 
Swimming term. It would also be useful to add both of these terms to a more general group 
such as Sport, this will then later allow you to search for: 

• ‘dive’ in all of your terminology, 

• ‘dive’ generally within Sport, 

• ‘dive’ within the context of Football or Swimming, 

• ‘dive’ just within the context of Football or 

• ‘dive’ within Swimming. 
 

4.1 Main versus Additional Descriptor 

The question that arises here is whether Sport or Football should be the main descriptor and 
which should be the additional descriptor? The answer is that it really doesn’t matter. Searching 
and reporting just within Football or Swimming or Sport is possible whichever way you decide to 
organise your data although searching only within the main descriptor may be slightly faster. 
The only restriction is how you wish to display your data on terminology reports and searches. 
 
Search and Report results can be displayed in one of two ways in Terminus: 

• A list of terms sorted alphabetically or 

• A list of terms grouped together by the main descriptor and sorted within each descriptor. 
 
Taking the above example and assuming that you organised your data using Football and 
Swimming as the main descriptors and Sport as an additional descriptor for all Football and 
Swimming terms, this would allow you to produce the following reports: 

• All terminology sorted alphabetically. 

• All terminology grouped by the main descriptor and sorted alphabetically within each 
group. 

• All Sport terminology sorted alphabetically. 

• All Sport terminology grouped by Football & Swimming, etc. and sorted alphabetically 
within each group. 

• All Football & Swimming terminology sorted alphabetically. 

• All Football & Swimming terminology grouped by Football & Swimming and sorted 
alphabetically within each group. 

• All Football terminology sorted alphabetically. 

• All Swimming terminology sorted alphabetically. 
 
If the descriptors are reversed so that the terms all have Sport as the main descriptor and 
Football or Swimming as additional descriptors, then the following reports are possible: 

• All terminology sorted alphabetically. 

• All terminology grouped by the main descriptor and sorted alphabetically within each 
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group. 

• All Sport terminology sorted alphabetically. 

• All Football & Swimming terminology sorted alphabetically. 

• All Football terminology sorted alphabetically. 

• All Swimming terminology sorted alphabetically. 
 
The important thing to remember is that if you want to produce a report where the terminology is 
grouped by the descriptor, the grouping is done only on the main descriptor. So, if the main 
descriptors for each term are Football and Swimming, it will be possible to produce a single 
report with the terms subdivided into these groups. If Sport is the main descriptor, both terms 
will always appear within the same section. In all cases, however, you will always be able to 
create a single report with all the terminology belonging to one or more descriptors. 
 
The best way to classify your terminology is to set the main descriptor to be as descriptive as 
possible of the subject in question and the additional descriptors to be a more general grouping. 
How ‘descriptive’ you wish this to be is, of course, up to you. 
 

5 Import / Export Format 

5.1 Text (CSV) 

Text import format should be comma-separated values (CSV). This is a standard format also 
used by Terminus to export data. 
 
The first row in the file is considered to contain column titles and each subsequent row contains 
data. A comma separates each column or value. All values should be quoted. The number of 
rows is unlimited but each row should have the same number of columns and match the 
number of titles given in the first row. 
 
An example file might look as follows: 
 
“Language_1”, “Language_2”, “Language_3” 

“Term_1_1”, “Term_1_2”, “Term_1_3” 

“Term_2_1”, “Term_2_2”, “Term_2_3” 

“Term_3_1”, “Term_3_2”, “Term_3_3” 

 
The languages are defined as Language_1, Language_2, etc. These values are used to map 
the data to the correct language on import. 
 
The remaining rows are the data. Each value in a column maps to the language defined in the 
first row and each row is a term in the various languages. 
 
Descriptors can be imported in exactly the same fashion. The column might be called, for 
example, Descriptor and should contain descriptors that have already been defined in the 
database. An additional descriptors column should contain a list of pre-defined descriptors 
separated by semi-colons (;). For example: 
 
“Language_1”, “Language_2”, “Language_3”, “Descriptor”, “Additional” 

“Term_1_1”, “Term_1_2”, “Term_1_3”, “Descriptor_1”, “Descriptor_2;Descriptor_3” 

“Term_2_1”, “Term_2_2”, “Term_2_3”, “Descriptor_1”, “Descriptor_2;Descriptor_4” 

“Term_3_1”, “Term_3_2”, “Term_3_3”, “Descriptor_5”, “Descriptor_2;Descriptor_3” 

 
The order of columns is not important. 
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5.2 Spreadsheet 

The spreadsheet format is similar to the Text/CSV format and the example above would look 
something similar to the following: 
 
 A B C 

1 Language_1 Language_2 Language_3 

2 Term_1_1 Term_1_2 Term_1_3 

3 Term_2_1 Term_2_2 Term_2_3 

4 Term_3_1 Term_3_2 Term_3_3 

 
Or, if you are importing terminology already classified with descriptors: 
 
 A B C D E 

1 Language_1 Language_2 Language_3 Descriptor Additional 

2 Term_1_1 Term_1_2 Term_1_3 Desc_1 Desc_2;Desc_3 

3 Term_2_1 Term_2_2 Term_2_3 Desc_1 Desc_2;Desc_4 

4 Term_3_1 Term_3_2 Term_3_3 Desc_5 Desc_2;Desc_3 

 
These values may be imported identically to the Text/CSV example. 
 
Terminus currently supports the following spreadsheet formats: MS Excel versions 97-2003 
 

6 Copyright 
Terminus is copyright © Nils Wintringham and is not free software. The unregistered version is 
provided only to allow you to try before you buy. If you use Terminus, please pay for it. 
 
The unregistered version is fully functional and is limited only in the number of entries that may 
be inserted. Upon registration any data that has already been added will still be available. 
 
Terminology entered into the system is the copyright of licence holder. 
 

7 Support 
If you have any problems, find any errors or just generally have any suggestions or requests for 
new features, please contact the support team: terminus@wintringham.ch 
 

8 System Requirements 
There are two versions of Terminus available for download. These are the minimum 
requirements for the Windows 2000 version: 

CPU Minimum requirement is a Pentium processor with a clock speed of 
at least 233 megahertz (MHz). Recommended as a minimum is a 
Pentium III or faster processor. 

Operating System Microsoft Windows 2000 Service Pack 3 (SP3) or later. 
Microsoft Windows Server 2003 or later. 
Microsoft Windows XP or later. 

Memory Minimum 128 MB. Recommended minimum 256 MB. 
Disk Space Terminus and run time libraries require approximately 50 MB. 
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Minimum requirements for the Windows XP version: 

 
CPU 500 megahertz (MHz) processor or higher 
Memory 256 megabyte (MB) RAM or higher 
Display 1024x768 or higher resolution monitor 
Operating system Microsoft Windows XP with Service Pack (SP) 2, 

Windows Server 2003 with SP1, or later operating system. 
Disk Space Terminus and run time libraries require approximately 150 MB. 
 
These values are based on Microsoft Office recommendations. 
 

9 Uninstall 
Terminus can be uninstalled using the “Add/Remove Programs” on the Control Panel. 
 
When un-installing or upgrading, you should always make back up copies of all your data files. 
 

10 Digital Signature 
If you download and install the Windows 2000 version of Terminus, you will be asked to verify 
the Digital Signature. The XP version is also digitally signed but you can probably ignore this 
section, as the user does not have to worry about verification.  
 
Digital signatures prove 

● who is the originator of the application, 
● that the code contained within the application has not been tampered with by a third-

party and 
● that the customer will not be installing some malicious code on his or her computer. 

 
The big advantage is that the user can be sure where the application originated. The 
disadvantage is that the user has to know a little about installing and accepting digital 
signatures. 
 
When you first start the application, you will be asked whether you trust and wish to run the 
application. The screen displays that the code has been signed by Nils Wintringham and if you 

check the certificate details (Details → View Certificate → Details) you will see the thumbprint: 
 

98 45 26 93 18 21 b8 b6 25 c7 be 6c c9 87 b8 6b fb 5f 67 fa 
 
If certificate matches the details above then you can be assured that the code that you are 
running has not been tampered with and you can safely run the application. 
 
If you do not wish to do this every time you start the application, I recommend that you click on 
the option ‘Always trust files from this publisher’. The application will then start automatically 
next time. 
 
If this option is not available then you should install the CACert root certificate using Internet 
Explorer as described below. 
 
If you are using IE7: 

• On the CACert website (www.cacert.org) select the Menu Option “Root Certificate”. 
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• Select the option 
” Class 1 PKI Key - Root Certificate (PEM Format)” 

• Open the certificate and check the fingerprint matches that displayed on the page 

• Select “Install Certificate” 

• Follow the instructions using the default options. 
 
If you are using IE5 or IE6: 

• On the CACert website (www.cacert.org) select the Menu Option “Root Certificate”. 
• Select the option  

“Class 1 PKI Key - Click here if you want to import the root certificate into Microsoft 
Internet Explorer 5.x/6.x” 

• Select ‘Yes’ to install the certificate 
 
For more information on installing the root certificate, please take a look at this FAQ: CACert 
Wiki 
 


